Verileri bulmak veya biçimlendirme uygulamak için koşullu formüller oluşturma


Verileri bulmak veya biçimlendirme uygulamak için koşullu formüller oluşturma

Şunlara Uygulanır: Excel 2016 , Excel 2013
 

Excel'de var olan koşullu biçimlendirme kuralları ihtiyaçlarınızı karşılamadığında, istediğiniz sonuçları elde etmek için kendiniz formül girebilirsiniz. Örneğin, koşullu bir formül kullanarak, boş hücrelerin bulunup kırmızı yapılmasını sağlayabilirsiniz. Böylece bu hücreleri kolaylıkla görebilirsiniz.

  1. Biçimlendirmek istediğiniz hücreleri seçin.

  2. Giriş > Koşullu Biçimlendirme > Yeni Kural'ı tıklatın.

  3. Biçimlendirilecek hücreleri belirlemek için formül kullan seçeneğini tıklatın.

  4. Bu formül doğru olduğunda değerleri biçimlendir ifadesinin altına formülünüzü girin.

  5. Biçim'i tıklatın.

  6. Verilerinizi ya da verilerinizin etrafındaki hücreleri değiştirmek için Sayı, Yazı Tipi, Kenarlık ve Dolgu sekmelerini kullanın.

Örneğin, negatif değerleri kalın ve kırmızı yazı tipine değiştirebilir, hücrelerin arka planına açık sarı dolgu ekleyebilir veya etrafına kesik çizgili kenarlık ekleyebilirsiniz.

Tüm açık iletişim kutularını kapatmak için Tamam'ı tıklatın.

İşte size bir örnek:

  1. Çalışma sayfasındaki tüm hücreleri seçin. Bunun için 1. satırın üstündeki ve A sütununun solundaki seçiciyi tıklatın.

  2. Yukarıdaki adımlarda 1 ile 3 arasını yineleyin.

  3. 4. adıma geldiğinizde =MOD(SATIR();2)=1 formülünü girin.İsterseniz formülü buradan kopyalayıp yapıştırabilirsiniz.

  4. Biçim'i tıklatın; ardından Dolgu sekmesini tıklatın ve renk paletinden bir mavi tonu seçin.

  5. Kuralı tamamlamak için Tamam'ı tıklattığınızda, çalışma sayfanızdaki her iki satırdan biri seçtiğiniz renge boyanır.

Biçimlendirme kuralında koşullu formüllerle yapabileceklerimiz bununla sınırlı değildir.

Koşullu formüllere örnekler

  • Boş hücreleri bulmak için önce sonuçlarınızı içerecek hücre aralığını (bir satır veya sütunu) seçelim ve sonra da ilk bölümdeki adımları bir kez daha uygulayarak bu formülü kullanan bir biçimlendirme kuralı oluşturalım.

    =B2=""

    Formülünüzde, B2 hücresinin yerine kullanmak istediğiniz ilk hücreyi yazmanız gerektiğini unutmayın.

  • Bir hücre aralığındaki yinelenen değerleri bulmak isterseniz de, benzersiz olmayan tüm değerlere biçimlendirme uygulayan şu formülü deneyebilirsiniz:

    =EĞERSAY($A$1:$D$11,D2)>1

  • Ortalamaları hesaplamak için şunu girin:

    =A1>ORTALAMA(A1:A14)

Koşullu formüllere yeterince alıştığınızda bir de buradaki örnekleri deneyebilirsiniz. EĞER,, VE ve VEYA mantığı kullanılan bu örnekleri Excel'in formül çubuğuna girmeniz gerekir (kural içinde kullanılamazlar), ancak size zaman ve emek tasarrufu sağlarlar.

  • İki koşulu karşılayan değerleri bulma: A2 hücresindeki değer A3'teki değerden büyük ve aynı zamanda da A4'teki değerden küçükse, Excel DOĞRU ifadesini görüntüler. Ancak A2'deki değer iki koşulu birden karşılamazsa, bunun yerine YANLIŞ ifadesini görürsünüz.

    =VE(A2>A3,A2<A4)

  • Bir koşulu karşılayan değerleri bulma: Bu örneğe göre, A2'deki değer iki koşuldan birini karşılıyorsa, yani A3'teki değerden büyükse ya da A4'teki değerden küçükse, Excel DOĞRU ifadesini gösterir.

    =VEYA(A2>A3,A2<A4)

  • Sonuç olarak DOĞRU veya YANLIŞ ifadesini görüntülemeyen formüller: Bu örnek formül, A2'deki değer A3 ve A4'teki değerlere eşit değilse "Tamam" ifadesini, aksi durumdaysa "Tamam Değil" ifadesini gösterir.

    =EĞER(VE(A2<>A3;A2<>A4);"Tamam";"Tamam Değil") görüntülenir.

  • Sayısal puana dayalı harf dereceleri ekleme: Bu formül, test sonuçları veya ürün derecelendirmeleri gibi herhangi bir puan türünü temel alan harf dereceleri ekler.

    =EĞER(D2>=80,"A", EĞER(D2>=75, "B+", EĞER(D2>=70, "B", EĞER(D2>=70,"B", EĞER(D2>=65,"C+", EĞER(D2>=60, "C","D"))))))

  • H arf dereceleri yerine "Geçti" ve "Kaldı" ifadelerini kullanma:

    =EĞER(D2>59;"Geçti";"Kaldı")


Bu makaleyi yararlı buldunuz mu?